Sins of a Solar Empire : Real-Time Strategy. Unrivalled Scale.
© 2003-2016 Ironclad Games Corporation Vancouver, BC. All rights reserved.
© 2006-2016 Stardock Entertainment

Advent Loyalist-only versions of culture research minidump

By on July 22, 2012 12:08:42 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

stein220

Join Date 12/2008
+12

I was able to successfully move the Advent culture center research to Tier 0 (1 lab required) for Advent Loyalists ONLY, by removing it as a pre-requisite for the first Advent culture spread rate research.

I did this by creating loyalist-only versions of the culture center module and culture center research entities so the module could be dependent on the research.  The advent rebels still had the research in tier 1 (2 labs) but the dependency was also removed from the first culture spread rate research.

This is OK but I wanted to preserve the original dependencies of all culture research.  I created loyalist-only versions of all research subjects that are dependent on the culture center research (culture vision, resist, psiorbitalcannon + module, etc.).

however, when I try to enable the "full version" of the mod, I get a mini-dump.  I've added all the new entities to the manifest and the PlayerPsiLoyalist.entity.  

Any ideas off the top of your head on what could be going wrong?  It works fine when I have just 2 new loyalist-only entities, but not when I have 10.

Locked Post 5 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
July 22, 2012 12:57:31 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

Run in the dev.exe and post any errors.

Reason for Karma (Optional)
Successfully updated karma reason!
July 22, 2012 2:46:06 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

I had one research position error that I fixed.

However, (after fixing some other things), it's not seeing one of the entities:

Entity Ref not found: PLANETMODULE_PSIORBITALCULTURECENTER_LOYALIST

Which is strange because:

1. the file exists and is listed in both the manifest and player entity file.

2. this file is used in the mod version that works.

I verified the spelling and the new AL entity files are mentioned at the bottom of the manifest.  If I put them near the original versions, I get errors about missing RESEARCHSUBJECT_ABILITYACCESS_DARKFLEET.entity.

Reason for Karma (Optional)
Successfully updated karma reason!
July 22, 2012 3:07:05 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

Are you sure you put that file in Entity.manifest?  A missing reference in that file is what usually causes Entity Ref not found errors.

EDIT: Did you update the entity count at the top?

Reason for Karma (Optional)
Successfully updated karma reason!
July 22, 2012 4:02:13 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

As a matter of fact I did not edit the entity count.  I'll do that when I get back home later tonight and report back.

Reason for Karma (Optional)
Successfully updated karma reason!
July 22, 2012 7:33:47 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

Quoting SpardaSon21,
Are you sure you put that file in Entity.manifest?  A missing reference in that file is what usually causes Entity Ref not found errors.

EDIT: Did you update the entity count at the top?

Sparda, you were correct.  I knew I was missing something simple like that.  Thanks to you both, that was a big help.

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108432  walnut2   Server Load Time: 00:00:00.0000343   Page Render Time: